Guide to Mandatory Homework for System Modeling

Critical Systems Research Group

2022
Contents

1 Installing Yakindu 1 2.2 Structure of project . . ... ... 4
1.1 Installing Java . . ... ... ... 1 2.3 Exporting your solution . . . . .. 4

1.2 Installing Eclipse . . . . ... ... 2
. . ) 3 Downloading, submitting, evaluating 4

1.3 Installing Yakindu itself . . .. .. 2
3.1 Homework Portal . . . . ... ... 4

1.4 Checking the installation . . . . . . 3
i ) . 3.2 Automatic evaluation. . . . . . .. 5

1.5 Yakindu Virtual Machine . . . . . 3
3.3 Forbidden elements . . . . . . . .. 6
2 Meeting the project 3 3.4 Known problems . ... ... ... 6

2.1 Importing the project . . . .. ..

Preface

The goal of this guide is to demonstrate the installation of Yakindu and the usage of the Homework
Portal to help solve the homework of the System Modeling course.

1 Installing Yakindu

This section is a guide to install the necessary software environment (sections 1.1. - 1.4.). As an
alternative, we provide a virtual machine to simplify the installation process (section 1.5.)

1.1 Installing Java

Yakindu is built on top of Eclipse, an IDE that primarily focuses on Java Developement. As the matter
of fact, Yakindu was written in Java to be able to work with Eclipse, so first a Java environment must
be installed. The JDK version should be at least 8, and at most 11.

The installation kit of Java Development Kit can be downloaded from the site of AdoptOpenJDK!.
On Unix based systems the package manager tends to have prebuilt packages to install the JDK, so
check it first, if applicable.

Attention! The JDK version to use is not the latest available JDK. It is important to use this
older version, as the newer editions are not compatible with the specified Eclipse version.

"https://adoptopenjdk.net/?variant=openjdkli&jvmVariant=hotspot


https://adoptopenjdk.net/?variant=openjdk11&jvmVariant=hotspot
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1.2 Installing Eclipse

The 18-12 version of Eclipse can be downloaded from the official site?. During installation, select the
Eclipse IDE for Java Developers option. The installation sequence after that follows the Next, Next,
Finish scheme, every settings value can be left on default.

Attention! The Eclipse version to use (18-12) is not the latest available Eclipse version. It is
important to use this older version, as the newer editions are not compatible with the specified
Yakindu version.

Comment. The installer does not always register a link in the Start Menu. If such scenario happens, you should open

the installation folder in the file explorer, and open the eclipse.exe/eclipse/eclipse.app executable manually.

1.3 Installing Yakindu itself

To install Yakindu, open up Eclipse first. After opening Eclipse, click on Help > Install new
Software... option from the menubar.

- Install v
Available Software
Check the items that you wish to install. 2R
Work with: | YAKINDU SCT - http://updates.yakindu.com/statecharts/releases/ - Add... Manage...
type filter text a Select All
Name Version Deselect Al

(- YAKINDU SCTUnIt Java Generator 3.0.1.201708041446

G- YAKINDU SCTUnIt Java Generator 3.0.0.201707181411

(- YAKINDU Statechart Tools 3.5.0.201901180803

(- YAKINDU Statechart Tools 3.4.3.201811121440

(- YAKINDU Statechart Tools 3.4.2.201810311453

(- YAKINDU Statechart Tools 3.4.1.201809171423

(- YAKINDU Statechart Tools 3.4.0.201808160934

(- YAKINDU Statechart Tools 3.3.2.201804191418

G- YAKTNDL Statechart Tonls 3.3.1.201804111327

1item selected

Details

TThe YAKINDU SCT feature contains the graphical statechart editor, the simulation engine and the code generation infrastructure to plug in
different code generators.

More...

Show only the latest versions of available software Hide items that are already installed
M| Group items by category What is already installed?

Show only software applicable to target environment

W Contact all update sites during install to find required software

@ Next> Cancel

Figure 1: Installing Yakindu in menu Install new Software...

The next step is to add a new source. To do so, click on the Add... button on the right. In the popup
fill the fields with the following values, then click on Add

— Name: Yakindu
— Location: http://updates.yakindu.com/statecharts/releases/

After adding the source choose the Yakindu source in the Work with field. Before continuing make
sure, that the Show only the latest versions of available software checkbox is not checked!

Now be extra careful! Choose only and exclusively the following packages to install:

— YAKINDU Statechart Tools Standard Edition > YAKINDU Statechart Tools version 3.5.2
— YAKINDU Statechart Tools Standard Edition > YAKINDU Statechart Tools Base version 3.5.2

’https://www.eclipse.org/downloads/packages/release/2018-12/r


https://www.eclipse.org/downloads/packages/release/2018-12/r
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— YAKINDU Statechart Tools Standard Edition > YAKINDU Statechart Tools Java Code Gen-
erator version 3.5.2

Attention! It is imperative to only install the packages mentioned above, and with the version
mention above. Our infrastructure was only tested with Yakindu version 3.5.2, using different
version can cause malfunction (happened before). Also, if you install any other package you risk,
that Licensemanagement package will be installed as a dependency. If that happens, Yakindu will
lock your installation until you provide a valid license. It that happens, uninstall Eclipse, and
start again from section 1.2.

After choosing the three packages mentioned above, the installation follows the Next, Next, Finish
scheme.

1.4 Checking the installation

It is recommended to check if the correct version of Yakindu was installed. To do so, click on Help
> About Eclipse IDE then on the Installation details button.

In the popup you can see the installed Eclipse plugins, including the different Yakindu packages.
Verify, that only the following packages are installed:

— Yakindu Statechart Tools version 3.5.2
— Yakindu Statechart Tools Base version 3.5.2
— Yakindu Statechart Tools Java Code Generator version 3.5.2

1.5 Yakindu Virtual Machine

To simplify the installation process, we provide a virtual machine?, that can be downloaded from
this link*. The virtual machine has all the required software components installed. To run the virtual
machine, VirtualBox® version 6.0 or above, or the latest version of VMware Workstation Player is
needed. The virtual machine might work with older versions, but it was not tested!

Comment. The virtual machine only has 2GB of RAM allocated. If the host machine has enough RAM, it might be a

good idea to allocate more!

2 Meeting the project

2.1 Importing the project

The downloaded .zip file contains a preconfigured Eclipse project that needs to be used to solve the
homework. To import it do the following:

— Click on File > Import...
— Choose in folder General option Existing Projects into Workspace

— Choose option Select archive file and browse for the downloaded .zip file. After choosing the
file, the project must appear in the panel in the middle part of the window.

— Click on Finish

After a successful import, the project must appear in the Project Explorer (usually on the left side).

3Credentials: remo/remo
‘https://share.mit.bme.hu/index.php/s/eyrWx7tPwk4rGAf/download?path=Y%2F&files=REMO.ova
Shttps://www.virtualbox.org/
Shttps://www.vmware.com/hu/products/workstation-player/workstation-player-evaluation.html


https://share.mit.bme.hu/index.php/s/eyrWx7tPwk4rGAf/download?path=%2F&files=REMO.ova
https://www.virtualbox.org/
https://www.vmware.com/hu/products/workstation-player/workstation-player-evaluation.html
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2.2 Structure of project
The preconfigured project has many files in it.

— tests: This folder contains the test cases. Please do not edit anything inside this folder, or you
might break something!

— yakindu: This folder contains Yakindu configuration files. Please do not edit anything inside
this folder, or you might break something!

— homework.sct: This is the Yakindu model you need to finish during your homework. You must
work in this file.

— homeworkEN.pdf: Your individual task. Read this, and not others’, because every homework
is different.

— Application.launch: Right clicking and selecting Run As > Application will GUI that you can
use to test your solution. (This file is only present in the project of the mandatory homework
assignment. )

— Simulation.launch: Right clicking and selecting Run As > Simulation will launch simulation
mode.

— Tests.launch: Right clicking and selecting Run As > Tests will launch the test evaluator. See
the results in the Console view.

Attention! Be advised, if your model contains errors (depicted as a small red x next to the projet
name), the tests will not launch (or if they do, they will give invalid results).

Comment. If something does not seem to work, make sure, that the Project > Build Automatically option is
checked.

2.3 Exporting your solution

After completing your solution, make sure that it is saved (Ctrl+S). After doing so, the .sct file must
be uploaded to the Homework Portal.

You must first find your .sct file in a file explorer. By right clicking on homework.sct and clicking
Properties, choose Resource tab and check the Location field. This field contains the path to your file.
Use this to find your file, and compress it, before uploading.

3 Downloading, submitting, evaluating

First and foremost check the System Modeling course page on the Moodle site” of the faculty for
detailed information about requirements and deadlines.

3.1 Homework Portal

To download your homework, first log in to Homework Portal® using BME EdulD / BME Cimtdr /
BME Central Login System. If the site is Hungarian, change it to English by clicking on the flag in
the upper right corner.

After logging in, choose the System Modeling course, then select the appropriate homework assignment
(warm-up or mandatory). After selecting the homework, the following information can be found on
the left hand side panel:

— URL: You can download your homework from this link.

— Deadline: The deadline until you can submit your homework. Be advised, the portal closes the
submission on time!

"https://edu.vik.bme.hu
Shttps://hf .mit.bme.hu/hallgato/vimiaa00


https://edu.vik.bme.hu
https://hf.mit.bme.hu/hallgato/vimiaa00
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— Late deadline: You can submit your homework late until this deadline (if applicable). Be
advised, you might have to pay, if you submit your solution late.

Individual task title: This is the unique identifier of your homework. Please always attach
this ID, if you report an error.

% BME-DMIS Homework Portal

Test Student 1 » System Modelling > Warm-up homewark

System Modelling: Warm-up homework

Task description Submission #1 (download)
URL: Click here to download! b 2019-02-17 16:40:45/ 2019- - i
Deadiline: 2019-03-10 - open Uploaded [ last updated: 02-19 14:50:00 State: automaied evaluation done
Late deadline: 2019-03-10 E-mail notifications: off (tum on Result: 4 paint(s) - accepted
g‘tfeif‘“’“a‘ task 626 HWRunner 2019-02-19 14:16:33 submitted
Individual task (N/A) Evaluation for homework
description: i
Lecturer: (N/AY Unknown error.
Maximum . -
= 4 point(s) HWRunner 2019-02-19 14:40:16 automated evaluation done 4 poini(s)
Minimum Evaluation for homework
result: CECEE)
4040
New submission Result of public test cases:
testl Succeeded!
ZIP file to upload: Choose File | No file chosen test2 Succeeded!

test3 Succeeded!
receive e-mail notifications about the submission testd Succeeded!
I agree to delete all previous submissions fo this
assignment by uploading this file
The uploaded file size must be under 10 MB.

Options:

Result of hidden test cases:
Upload

testl Succeeded!

test2 Succeeded!

test3 Succeeded!

testd Succeeded!

Figure 2: Homework Portal

You can use the bottom left panel to submit your solution. Your submission must be a .zip file and
must not contain anything else but the .sct file containing your solution. So the .zip file most not
contain any other project files like . java or .sgen files, and your .sct must not be inside subfolders;
it must be in he root of the .zip.

Attention! If the .zip file contains anything else than the .sct file, your submission will be
rejected!

Attention! Submitting a new solution irrecoverably deletes your former solution!

Attention! Make sure, you upload the .sct file you have been working on, and not the one in
the starting project. For more information check section 2.3.

3.2 Automatic evaluation

The evaluation of the submitted homeworks is automatic and happens every 2 or 3 days. This auto-
matic evaluator script will award your points.

Like every program, the automatic evaluator can be mistaken as well. If you feel, that the given
evaluation is wrong, you can apply for a defense at the end of the semester. Check the course page on
the Moodle site” of the faculty for further details.

Attention! We will run automated plagiarism test on all submitted solution. Plagiarism is a
serious offense, and results in instant failure of the entire course!

The automated evaluator script is a tool that can help you if you use it in time. Do not leave your
submission for the last 48 ours, because we cannot guarantee 24—7 support operating the evaluator.

‘https://edu.vik.bme.hu


https://edu.vik.bme.hu
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3.3 Forbidden elements

Yakindu supports a wider set of language that is allowed during the System Modeling course. These

elements usually offer functionality for other use cases which are not discussed in this course, so we
forbid them.

Be advised, that the presence of forbidden elements is automatically checked by the automatic evalu-
ator script. Submissions containing forbidden elements will be automatically rejected!

The list of forbidden elements:
— always
— oncycle
— Triggerless transitions (in Yakindu this is equivalent to the two above)

— after Os / after Oms / every Os ...
— [trigger && condition] as a transition trigger

3.4 Known problems

3.4.1 Increment operators

Yakindu supports the ++/-- preincrement, postincrement, predecrement, postdecrement operators.
However the Java code generator emits source code with syntax errors if they are used in a model,
which will result in build error. Please use +=1/-=1 instead.

3.4.2 New line characters

Make sure to check whether there are new line characters in strings you enter. The code generator
does not escape the new line characters and as a result it emits code with syntax errors.



	Installing Yakindu
	Installing Java
	Installing Eclipse
	Installing Yakindu itself
	Checking the installation
	Yakindu Virtual Machine

	Meeting the project
	Importing the project
	Structure of project
	Exporting your solution

	Downloading, submitting, evaluating
	Homework Portal
	Automatic evaluation
	Forbidden elements
	Known problems


